SocketTools .NET 5.0 Framework

Microsoft has released the .NET 5.0 Framework and it is available with Visual Studio 2019 16.8.3 and later versions. Use the Visual Studio Installer to check what version you have installed and update to the current release.

Important: The .NET 5.0 Framework reaches end-of-support on May 8, 2022. It is recommended that you upgrade your projects to use .NET 6.0 which is a Long Term Support (LTS) release.

SocketTools .NET 10 Build 1260 and later versions include assemblies which target the release version of the .NET 5.0 Framework as part of the base product. Support for .NET 5.0 is only available with SocketTools 10 and later versions.

To work with the .NET 5.0 Framework, you will need to install the current release of Visual Studio 2019 or Visual Studio 2022.

You can use these download links for the current version of Visual Studio and the .NET 5.0 Framework.

  Visual Studio 2022
  Microsoft .NET 5.0

The minimum required version of SocketTools is 10.0.1290.2024, released on 08 Nov 2021. If you have an earlier version of SocketTools, you will need to upgrade to the current release. This update is free to developers who have a version 10 license.

SocketTools Build 1290 and later includes support for the .NET 5.0 assemblies as part of our standard distribution. We will not be backporting support for .NET 5.0 to previous versions of SocketTools.

SocketTools 10 remains focused on Windows desktop and server development and will only provide support for those platforms. If you have any questions about using the .NET 5.0 assemblies, please contact us.

See Also

SocketTools .NET 6.0 Framework
SocketTools .NET 7.0 Preview
Referencing .NET Core Assemblies